Bugzilla – Bug 4
Cryptic Time API
Last modified: 2008-07-01 13:32:11 UTC
As I explained in [1], the current ns3 Time API contains very cryptic method names S(), nS(), and uS(), which I argue are harmful for code readability. I suggest renaming to Seconds(), MicroSeconds(), NanoSeconds(). I also argue that the extra typing does not really affect much code in practice because convertion of Time() to a numeric value is (or should be) seldom necessary. [1] http://mailman.isi.edu/pipermail/ns-developers/2006-October/002468.html
The new methods are named GetSeconds, GetMicroSeconds, GetNanoSeconds, etc.